PSIRT Advisories

FortiOS & FortiProxy - Stack-based buffer overflows in diagnostic CLI commands

Summary

A stack-based buffer overflow vulnerability [CWE-121] in the command line interpreter of FortiOS and FortiProxy may allow an authenticated attacker to execute unauthorized code or commands via specially crafted command line arguments.

Affected Products

FortiProxy version 1.0.0 through 1.0.7
FortiProxy version 1.1.0 through 1.1.6
FortiProxy version 1.2.0 through 1.2.13
FortiProxy version 2.0.0 through 2.0.7
FortiOS version 6.0.0 through 6.0.14
FortiOS version 6.2.0 through 6.2.10
FortiOS version 6.4.0 through 6.4.8
FortiOS version 7.0.0 through 7.0.2

Solutions

Upgrade to FortiOS version 7.0.4 or above,
Upgrade to FortiOS version 6.4.9 or above,
Upgrade to FortiOS version 6.2.11 or above.

Upgrade to FortiProxy version 2.0.8 or above.

Acknowledgement

Internally discovered and reported by Giuseppe Cocomazzi of Fortinet Product Security team.