PSIRT Advisories

FortiProxy - Stack-based Buffer overflow vulnerability through the diagnose sys cpuset CLI command

Summary

A stack-based buffer overflow vulnerability in FortiProxy physical appliance CLI may allow an authenticated, remote attacker to perform a Denial of Service attack by running the `diagnose sys cpuset` with a large cpuset mask value. Fortinet is not aware of any successful exploitation of this vulnerability that would lead to code execution.

Affected Products

FortiProxy versions 1.2.9 and below.
FortiProxy versions 2.0.1 and below.
FortiProxy versions 1.1.x
FortiProxy versions 1.0.x

Solutions

Please upgrade to Fortiproxy version 1.2.10 or above.

Please upgrade to Fortiproxy version 2.0.2 or above.

Acknowledgement

Internally discovered and reported by Wilfried Djettchou of Fortinet Product Security team.