Buffer overflow vulnerability in FortiProxy SSL VPN through a crafted POST request


A buffer overflow vulnerability in the SSL VPN portal of FortiProxy may allow an unauthenticated, remote attacker to perform a Denial of Service attack by sending a specifically crafted POST request with a large msg value.

Affected Products

FortiProxy versions 2.0.0
FortiProxy versions 1.2.8 and below.
FortiProxy versions 1.1 all versions
FortiProxy versions 1.0 all versions


Please upgrade to FortiProxy versions 1.2.9 and above. Please upgrade to FortiProxy versions 2.0.1 and above.


Fortinet is pleased to thank Meh Chang and Orange Tsai from DEVCORE Security Research Team for reporting this vulnerability under responsible disclosure.