Threat Encyclopedia

Security Vulnerability CVE-2021-3115 for Go Programming Language

description-logoDescription

Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the \"go get\" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).

affected-products-logoAffected Applications

Go Programming Language

CVE References

CVE-2021-3115

Telemetry logoTelemetry